Original Post — Direct link

I've been playing through Valhalla for the second time. Everything went fine until I got to the scene in "War Weary" where the player has to choose to whom he will give some silver. I saved my progress and exited at that point this AM. This afternoon I can't get any of the half-dozen latest saves to load. It looks normal until I click "Continue" -- about five seconds later, the game closes. This was true after I verified game files. It may be coincidental, but I recall a short "update" being downloaded and installed while I was playing this morning; this is the first time I've tried to load the game since then. As far as I can tell, I'm playing version 1.5.1.

My system specs follow:
   CPU: Intel Core i7 10700F 2.90GHz (4.80GHz Turbo Boost), 8-Core 16-Thread
   GPU: NVIDIA GeForce RTX 3060 12GB
   Motherboard: ASUS TUF Gaming B460M-Plus, WiFi 5
   RAM: 16GB DDR4 3000MHz (2x8GB)
   SSD: 1TB M.2 NVMe SSD
   HDD:   Western Digital Blue 1 TB   
   CPU Cooler: RGB CPU Cooler
   PSU: 700W 80 Plus Gold
  Operating System: Windows 10 Pro 64-bit

   Monitor: LG 24GM77
   Mouse: Steelseries Rival 310 eSports
   Keyboard: Steelseries Merc Stealth
      Controller: Razer Wolverine Ultimate
      Speakers: Philips SPA 2210
      Microphone: Blue Yeti

Case: Thermaltake Level 20 MT ARGB CA-1M7-00M1WN-00 Black SPCC / Tempered Glass ATX Mid-Tower Computer Case    Dimension: 18.54" x 8.00" x 17.90"
WiFi: Yes
Bluetooth: Yes
VR Ready: Yes

Internet connectivity:

   2022 02 22 -- Ping 25, DL 13.13, UL 0.83
   2022 04 27 -- Ping 29, DL 13.14, UL 0.81

20 days ago - Ubi-Froggard - Direct link

Hey @anan_isapta

That' interesting that this resolved the issue you were having. Thanks for letting us know and sharing it here.

If anyone finds the same fixes an issue for them too, please comment here to let us know.