Original Post — Direct link

Hi has anyone had an issue trying to get the Amber shard the The Mist, I have killed him but I can't confirm it seems to be in the rocks, is this a glitch as this is the only one I need now, ive tried coming back after completely gone other quests but still no look

4 months ago - Ubi-Mark. - Direct link

Hello @danfox3388,

Sorry to hear that you are unable to confirm this kill.

Can you please provide us with more details i.e. on what platform are you currently playing along with a shot video of this occurring? It will help us to investigate it further for you.

Many thanks and if you have any additional questions, please let us know.

4 months ago - Ubi-Mark. - Direct link

Hello @danfox3388,

Thanks for the update. As you mentioned pictures, can you please provide us with a short video? You can upload it to any streaming service of your choice and share the link with us here 🙂 Many thanks!

4 months ago - Ubi-Mark. - Direct link

Hello @danfox3388,

Thank you for your video!

I passed it along to the development team for further investigation. Once we have an update, we are going to let everyone know through the patch notes.

Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

17 days ago - Ubi-Woofer - Direct link

Hey there @danfox3388 - I sincerely apologise for the lack of recent update to your thread.

Checking in on the investigation opened by the development team, it does not appear that we have received any additional reports of this issue since your own so far. The team are still looking into the issue, however it is unclear if they have been able to reproduce it as yet. I've reached out to the team to try and clarify where they are at, and if there is anything that they are able to do about the issue. It may be that this issue is isolated to your playthrough and cannot be widely reproduced, and if this is the case, it may be more difficult for us to troubleshoot.

Thank you for your patience and understanding in the meantime, as I can fully appreciate that this issue has been ongoing for some time now. 🙂






Recent Assassin's Creed: Valhalla Posts

about 10 hours ago - Ubi-Viral
about 14 hours ago - Ubi-Viral