Original Post — Direct link

Hi, Valhalla keeps crashing for me every time I have tried to open it. I have uninstalled and reinstalled both the game and ubisoft connect. I have verified the files, I have set the game as admin to try and get it to run that way but has not worked. I just want to be able to play but have no clue what else I should do to try and get it to work. Please let me know if anyone has ran into the same issues or any other ideas of things I should try.

10 days ago - Ubi-Nacho - Direct link

@dgrosso80 Hello there!

Really sorry to hear you've not been able to boot the game up. Could you let us know if you have been able to launch the game in the past, or if you have always had this issue?

Would you also let us know if you are seeing any particular error messages?

If you haven't already seen our troubleshooting guide, you can see instructions on what to do when your game won't launch here.
Hope this helps!






Recent Assassin's Creed: Valhalla Posts

about 5 hours ago - ubi-smash
about 8 hours ago - ubi-smash