Original Post — Direct link

Ive been dealing with this for 12 hours of my day just trying to access content that I payed for! Ive had all three dlc (not ragnörak) for a bit and decided to pick up Valhalla again but no matter what Ive done it just says new content available, and the content wont load in ever. Ive reached out to support and they’ve given me no help other than “make sure the content is downloaded” yea no duh Ive been deleting it and reinstalling it for 3 days before I reached out, I apologize and I bet you all are nice people but Ive just been exhausted with this, Ive tried reinstalling the content along with the entire game even the xbox trouble shoot and nothing has worked, Im on an xbox 1 if that helps

4 days ago - Ubi-Thrupney - Direct link

Hey there @Babytom09 , thanks very much for getting in touch about this. I understand you've not been able to access your DLCs for Valhalla on your Xbox One, even though they are installed - sorry about this! I'll be happy to share some insights with you from here on the forum.

As far as I can see by looking around internally, this isn't an issue that has otherwise been reported, so I'm really keen that we get this issue investigated. Once we've done that, we'll have a better understanding of what is happening, and can suggest a solution. Here on the forums, we're limited in what we can do, since we're not able to discuss your account directly publicly.

You'd mentioned getting in touch with our support teams directly, which is great to hear. I understand they've shared some troubleshooting, and it hasn't worked - that's unfortunate for sure, but it's important that we get our usual fixes out of the way first, in case they worked. If you go back to our support teams on your ticket, and explain that the troubleshooting hasn't happened, I'm confident they'll be keen to investigate this further from there (and will probably have asked for screenshots or media showing the issue, which we can use to try to copy the same steps from our side).

So, while I'm not able to help directly from here on the forums, I'd like to encourage you to continue to work with our support team to help get to the bottom of this issue. Let me know if I can clarify this at all 🙂






Recent Assassin's Creed: Valhalla Posts

34 minutes ago - Ubi-LadyBlue
about 7 hours ago - Ubi-Greybeard