Original Post — Direct link
I've had this problem several times now. The user interface is completely removed and doesnt come back.
I can still CTRL+S, Enter to save. I need to restart by spamming ALT+F4 and restart the game.
15 days ago - Ubi-Thrupney - Direct link
Thanks for reporting this to us, guys! Certainly difficult to play the game with the UI disappearing, so I'd really like to help.

For those who are able to, can you try running the game in DirectX 11, and see if this solves the issue? You can change this at:

%userprofile%\Documents\Anno 1800\config\engine.ini

And changing the line ("Device Type": "DX11",) to ("Device Type": "DX12",).

Does that seem to solve the issue? Let me know if so, as that'll be useful information to pass on to our devs for investigation.

In addition, if you can all be sure to verify your game files, and make sure your drivers, OS, and supporting files (such as DX, of course) are updated, as explained by our troubleshooting article, that'd be great.
8 days ago - Ubi-Karl - Direct link
Originally Posted by SirHarryPierce
Can confirm hitting this bug.
Hey SirHarryPierce, have you tried steps proposed earlier by any chance?

Originally Posted by Gausor
Going to Direct X11 solves it for me. But this should not be the all time solution. Drivers and everything up to date as everytime.
Hi Gausor, thanks for letting us know and I'm glad to hear this.

I appreciate your feedback on the matter and we will continue to actively monitor these reports.
6 days ago - Ubi-Karl - Direct link
Originally Posted by attenzionee
Morning,

same bug for me since the latest Update.

Im on DX12 with all the latest GPA drivers.
Hey attenzionee thanks for reaching out and sorry to hear about this.

For reproduction purposes, so that we could look into the matter further, would you be able to clarify the following:

1. In what instances does the problem occur? Are there any particular actions in-game that you've noticed that may lead to this?
2. How often do you experience the problem?
3. Is there any chance could you provide us with video footage of this?

In the meantime, there are a few workaround steps mentioned in the thread, therefore if you haven't tried those yet, you can give it a go and see if it helps.

Keep us updated!
1 day ago - Ubi-TheBerry - Direct link
Hey there guys!

Thank you for getting back to us with these updates, and for the clip SirHarryPierce!

We've passed these details onto the team who will begin to investigate this further.

Should anyone else encounter this issue, please post your response to Ubi-Karl's questions above so we can pass them on.

Otherwise, we'll let you know when we hear any further news.

Thank you!





Links in this thread

General PC Troubleshooting
General PC Troubleshooting


devtrackers.gg