Original Post — Direct link
Bug: all Club Rewards are locked, whether decorations and skins in saved games or portraits when starting new games.

Additional information:
I am logged in when launching the game, and clicking Ubisoft Club brings up a sidebar with my profile where all rewards are unlocked.
I have also tried exiting Ubisoft Connect and opening it again, as well as logging out and logging back in.
Don't know if this is necessary since the shift to Ubisoft Connect should have them all unlocked, but it's all rewards that are locked, including those I bought with Uplay points before the shift.
4 months ago - Ubi-Orion - Direct link
Hey there folks.

Just to confirm that this issue is under active investigation at the moment. Apologies for any inconvenience caused whilst we're working on this.
4 months ago - Ubi-Raziel - Direct link
Originally Posted by tmaximus2284
I have the same issue upon reinstalling the game.
Hey! Not to worry, we're working on this issue and we hope to have a fix implemented soon

Leave this with us!
4 months ago - Ubi-Thorlof - Direct link
Since the issues are related to Ubisoft Connect which was launched in late October, the issue can't exist in 2018.

For anyone affected by the recent issue with the Club/Connect Rewards being shown as unlocked in Ubisoft Connect itself but are locked in the game, could you please provide info on the following points?
- Are you using mods?
- Are you playing offline?
- Do you have the game updated to the latest version? (9.1.968978)
- Did you receive any popups in-game or from the Connect Client (at the bottom of the game)
3 months ago - Ubi-TheBerry - Direct link
Hey there guys!

The team are looking into issues with certain legacy titles, including Anno 1800 where Ubisoft Connect rewards haven't been unlocking properly.

Rest assured this is under investigation at the moment, sorry for the inconvenience caused!
3 months ago - Ubi-Milky - Direct link
Thank you for confirming and thank you for the screenshot perhapsanap, I will add this to the report.

Have you also tried verifying your game files and reinstalling the game? If you gave tried those steps, are you still unable to use the new portraits when starting a new game or add the ornaments to your town such as the duck pond?
3 months ago - Ubi-Milky - Direct link
Thanks for the screenshot image CoreOfKallisto, I believe we should have enough information now for our investigation into this. When I hear back from the team I will do my best to update you.
3 months ago - Ubi-Milky - Direct link
Hello everyone, sorry to see so many of you have not received your rewards in game yet.

This is still being investigated for Anno 1800 as we managed to resolve this issue for some of our other games that had the same problem.

Just to clarify -
- For some the rewards appear locked and do not have a green tick
- For others the rewards appear unlocked, but are not accessible in game

I would like to add a screenshot to our investigation if anyone could provide one?

As always if you haven't already done so -
- Make sure you are using game update 9.1
- Please make sure to download the new Ubisoft Connect game launcher from this link if you have yet to update or if your client shows as Uplay in the menu - https://ubisoftconnect.com
- Please try deleting the cache folder for Uplay - https://support.ubisoft.com/en-gb/Article/000061966
- Try verifying the Anno 1800 games files too - https://support.ubisoft.com/en-gb/Article/000060529

Out of curiosity, does anybody still have the older version on Uplay installed as well?

I hope we can update you with a resolution soon, sorry for any inconvenience caused by this.
3 months ago - Ubi-Milky - Direct link
Thanks for the screenshot also AsWarning.

What paid for DLC content have you no longer access to as certain parts of DLC are only unlockable after progressing so far through the game, if you could let me know?

Can I just make sure your DLC was purchased in the same launcher such as Ubisoft Connect, as DLC bought from other launchers may not be compatible if the base game was bought in Anno 1800 - https://support.ubisoft.com/en-GB/Article/000062891
3 months ago - Ubi-Milky - Direct link
Thanks for clarifying that AsWarning, I had to be sure first of all where you bought the extra DLC content first.

I have all of the DLC content and Rewards unlocked on my version of the game too, but the rewards are not usable for me either when starting a new campaign after just installing the latest update. I will do some troubleshooting too and see if I am able to unlock them like some of the previous players were able to in this thread. I will let you know the outcome after running some tests over the next few hours.

In the meantime, I have added all the information you have given me to help with our investigation so thank you for being a good sport, I hope I can update you with a solution soon.
3 months ago - Ubi-Milky - Direct link
Hey everyone just a quick update about these rewards, I have sent some of my game files over to the team investigating this. Stay tuned for further updates on this, we may need to acquire some other players files too, if so I will make a quick post in this thread requesting this, thank you for your patience whilst we try to resolve this.
3 months ago - Ubi-Thorlof - Direct link
Originally Posted by aka_Celador
I have that problem since release
The issue discussed in this thread appeared with the switch from Uplay to Ubisoft Connect at the end of October this year.
If you're having issues with the rewards since the release in April 2019, I'd ask you to open a separate thread for that since that would be unrelated.


The issue here is still under investigation by the Ubisoft Connect team who we're working with on this matter.
As soon as we have news, we will of course let you know.

Apologies for the inconvenience.
2 months ago - Ubi-Thorlof - Direct link
Originally Posted by Altoria_canarin
Hi,
greetings from germany, we have also a forum discussing the missing club rewards and we also don't get any statement from ubisoft. Like you we are waiting for a fix since october and it's really getting on my nerves.
This is not true, since we replied several times both in the English and the German forums - as well as to questions on Reddit and the social channels.

We do not yet have an update on this issue, but will let you know as soon as we have news.


@Pine_RS: Which DLC that you paid for are you missing? The Rewards this thread is about is specifically about content that was unlockable via the Ubisoft Club (now Ubisoft Connect)
2 months ago - Ubi-Thorlof - Direct link
Unfortunately, we currently do not have an ETA for the fix, that's why we have not communicated a date yet.

@Pine_RS: No worries. The issue with "unlocked but locked" to our knowledge only affects the "rewards" in Ubisoft Connect, which were supposed to be unlocked for everyone with the switch from Uplay to Ubisoft Connect. These items:

If you have purchased any DLC and are unable to access those, please get in touch with our support so they can investigate further (https://support.ubisoft.com/)
about 1 month ago - Ubi-Raziel - Direct link
Hello all!

As you can see above, a workaround was found by a member of our community which is great this has been a frustration for some players, so we're happy to see the light at the end of the tunnel.

Our team are hoping to have a permanent fix implemented in the near future
about 1 month ago - Ubi-Raziel - Direct link
Hello everyone!

I'm happy to see a workaround has been found, thank you for sharing that with the community.

Our team will have their workaround implemented soon so we can make sure it is resolved for all players.

All the best!
about 1 month ago - Ubi-TheBerry - Direct link
Hey there guys!

For those of you still unable to access some Club / Connect Rewards, sorry for the inconvenience!

This has been under investigation with the team, so reset assured work is ongoing to resolve this

We'll keep the forums updated as and when we receive further information regarding this or any dates to expect a fix

Thank you for your patience!
about 1 month ago - Ubi-TheBerry - Direct link
Hey there guys!

For those of you still unable to access some Club / Connect Rewards, sorry for the inconvenience!

This has been under investigation with the team, so reset assured work is ongoing to resolve this

We'll keep the forums updated as and when we receive further information regarding this or any dates to expect a fix

Thank you for your patience!
about 1 month ago - Ubi-Thorlof - Direct link
We're currently working on a fix for this issue that will be included in the next Game Update (9.3). More info on this soon
17 days ago - Ubi-TheBerry - Direct link
Hey there guys,

daqoos7ar, I've merged your thread here as it relates to the same issue.

We've been aware of issues with redeeming Ubisoft Connect content since the migration from the Club last October.

However we have received news a fix is aimed to be released in Patch 9.3

Please keep an eye on https://www.anno-union.com/en for updates and patch notes regarding this update when it becomes available

Thank you for your continued patience and sorry for the inconvenience!
10 days ago - Ubi-Thorlof - Direct link
Hey, for the issue of the ornaments being locked in-game:
Could you please try verifying the game files (https://support.ubisoft.com/en-GB/Ar...ct-Desktop-App) followed by a restart of Ubisoft Connect.

This should unlock the ornaments in-game.





Links in this thread

Verifying game files in the Ubisoft Connect Desktop App
Verifying game files in the Ubisoft Connect Desktop App


https://www.anno-union.com/en


Verifying game files in the Ubsioft Connect Desktop App
Verifying game files in the Ubsioft Connect Desktop App


Emptying the cache of Ubisoft Connect
Emptying the cache of Ubisoft Connect


Explore - Ubisoft Connect
Connect with Ubisoft players, enjoy Rewards and discounts, compare your stats with your friends and much more in Ubisoft Connect.


Home - Ubisoft Support
Ubisoft Support Homepage is where you will find help about Ubisoft games and services. You will be able to search for your problem, browse FAQs, get game service status, view most popular forum posts, submit a case and chat with an agent.


devtrackers.gg