Original Post — Direct link

Hi guys,

I'm playing on PS4.

I've reached the point in the quest where I've confronted the Seax's sister and she's run into a side room. She's called for guards to help her but none have arrived and I cannot speak to her which means I cannot progress. Because I spent so long trying to fix this myself (closed/restarted the game, tried to use a previous save during the quest, meditated etc) my previous save is hours before this in Asgard and I REALLY don't want to redo everything!

All I did before the quest was the Assassin's bureau.

Have you got any advice?

Cheers,

JSC

over 1 year ago - Ubi-Mark. - Direct link

Hello Vikings,

Sorry to hear about your experience.

After checking this for you, I can see that this issue has been already reported to the development team and it's currently being investigated. Once we have an update, we are going to let everyone know through the patch notes. Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

about 1 year ago - Ubi-Mark. - Direct link

Hello @sauliukas621,

Thank you for sharing your workaround!

I can see that this issue is still being worked on in order to resolve it. Apologies for any inconvenience and thank you for sharing again!

11 months ago - UbiStorm - Direct link

Hi everyone! This issue still appears to be under investigation. I do apologize for the frustration! If anyone does try the workaround that @atlas_79 reported, please let me know!

20 days ago - UbiSushiVamp - Direct link

@bosbe Hello! I am happy to hear that uncloaking helped you complete this quest. I hope you have a happy rest of your day! 😊