Original Post — Direct link

I'm playing the game on Xbox Series X and on LG CX. I'm running Xbox in 4K120Hz with VRR enabled. Every time I am in a more populated area (like a town), then the game starts to randomly stutter. The stutter happens at random intervals inside a town and seems to get more severe the longer I stay in a town. The framerate seems to be stable, just that there's a small hitch at random intervals. It even stutters if I'm inside a house with no NPC's visible.

Some strange things that I have noticed:

There's is no stuttering if I participate in river raids (separate map from England), even when raiding large settlements with a lot of enemies.

Another thing is if I restart the game, then it runs fine but after playing for about 15 minutes, then it starts to stutter again.

So far I have tried to play in offline mode, changed Xbox resolution to 1080p, 60 Hz, disabled VRR, disabled HDR, disabled 4K option. None of these changes helped.

Does anyone else has this issue?

21 days ago - Ubi-Keo - Direct link

Hi @Atreon117 I'm sorry to hear that you are experiencing micro stuttering whilst in populated areas.

We are aware of an issue where micro stutters can occur from time to time whilst the game is auto saving, do you notice the save icon appear on the screen when you encounter this issue?

Can you also confirm the following:

  • Is the game installed on your internal or an external drive?
  • Are you using the quick resume feature when you play the game?
19 days ago - Ubi-oof - Direct link

@Atreon117 Thank you for confirming that for us! For good measure, we would like to tackle some basic troubleshooting steps before we proceed. Please start with these:


Once those have been completed, if this is still happening, a short video clip would be very helpful! Please let us know if you see any improvement and if not, I'll be more than