Original Post — Direct link

The prisoner/quest giver isnt there

10 months ago - ubi-smash - Direct link

Hey @suddz, the development team has been made aware of this issue and they are currently investigating it. In the meantime, our teams would like to use details from your progress on Assassin's Creed: Valhalla to make further research. Please make sure that your latest save has been added to the Cloud. This step will allow them to use your saved files for investigations. Would you be able to confirm that you have completed Part I of this mystery, in Ledesctrescire? Are the NPCs still around the house, in that location? My apologies for any inconvenience this has caused, but thank you for your patience and understanding while we work to resolve this issue.

3 days ago - Ubi-Oxavo - Direct link

Hello @jakhi147 and thanks for letting us know that issue has been solved for you after reloading, happy to hear that!

Hey @MarkThis9 , I am sorry to hear the issue still persist for you. Have you tried the workaround provided by @markangelolicup , did it work for you? If no, could you please record the video of the issue, upload it on any hosting of your choice and send us the link so we can investigate?

@markangelolicup , thanks for your input, we appreciate it.

Please let us know if you have additional questions.