Original Post — Direct link

For context, I am on Xbox series S so my game is all digitally installed. The content I should be able to access from the Season Pass in AC Valhalla is not working. Everytime I open the game up it says that new content is available and my saves are out of date. It did not use to be like this. For example, I already have completely completed The Wrath of the Druids but now it claims it isn’t there. I moved to college for the and now all my additional DLC content is not there. I am trying to start the Siege of Paris but the content is not there. I have everything downloaded to my Xbox so that isn’t the issue. I also just bought the new dlc Wrath of Ragnarok and I’m not sure that’s appearing either. I have tried uninstalling and reinstalling a handful of times along with moving back and forth from external drive. Nothing is working. It’s just like the game isn’t recognizing it’s there. Does anyone know a solution to this? Any and all help is much appreciated. Thanks.

9 days ago - Ubi-Perseids - Direct link

@TheBigJA3 Hey there! Welcome to Discussions!

So sorry that you aren't seeing the DLC content appear in your game. 😞 Hopefully, we can get this figured out so that you can enjoy the content!

To start with, can you double-check to make sure that your content has been installed? Here is how to do that. If you're still not seeing your content, please follow this guide. Next, if you can, please take an image showing your DLC/add on content installed so we can have a closer look. Thanks!

7 days ago - Ubi-LadyBlue - Direct link

Thanks for grabbing us those images @TheBigJA3,

Are you playing on the same account that you used to purchase both the game and the DLC originally? Additionally, are you doing any game-sharing?