Pathfinder: Wrath of the Righteous

Pathfinder: Wrath of the Righteous Dev Tracker

16 Mar


Already fixed internally, just waiting for the update to deploy. Expecting before the end of the week.


Already working on this problem, should be fixed in the next update.

15 Mar


Originally posted by matheuxknight

Thanks u/OwlcatStarrok

In the video you can see I’ve cleared the left side of the map previously - pre latest patch. I’m now on the right side of the map next to the bridge. Talking with the Axeman seems to indicate he’s cool with me moving across the bridge, but I keep hitting that invisible barrier and being teleported back each time.

I’ve tried the other bridge with the two guards just north, but no success. I’ve also tried using dimension door in just about every possible location that might get me across, but only get “target is invalid” messages.

I feel like there’s a flag which takes down the invisible barrier which I previously acquired taking to the Axeman previously, but it reset in the latest patch. The Axeman probably has another flag for completed dialog and his flag remains so I have no way to retrigger the removal of the barrier.

Thank you. I've checked up with the QA team, the fix for this will be coming in the nearest hotfix before the end of this week.

Update: Correction, apparently it's scheduled for 1.14, next after the hotfix.


Originally posted by matheuxknight

u/OwlcatStarrok I can send you a video or screenshot if that helps. I’m at the point where I’m about to finish Act 3 in the Midnight Fane, so I’m putting the game down until I can get past the bridge again and also get past that one dialog with the wolf spirit.

Please do.

14 Mar


Originally posted by BrotherMaxwell9143

Hey OwlCat, I’m having an issue as of Sunday. I bought the game and dlc for the ps5 and everything was running fine until I got to the camp right right before the lost chapel. I beat the gargoyles, but now, whenever I try to exit the counsel tent to move to the lost chapel, the game loads to 100%, gives me the page flipping sound, and kicks me back to the main menu with a teleport bug message displayed. I’ve submitted 2 bug reports, and I’ve started a new play through. That being said, do you have any fixes? I’ve already tried reloading earlier saves, reinstalling the game, and restarting the console

Hello, thank you for the report! Yeah, we're already aware of the problem, hotfix is on the way, should be live before the end of the week.


Originally posted by Salty_Reputation_742

Just bought it and it’s not showing

Can you please PM me a screenshot of DLC not working, any proof of purchase (receipt etc.) and your region? We'll check.


Originally posted by Salty_Reputation_742

The last sarkorians not working on PS5 anyone having this issue?

Can you please clarify what exactly isn't working? You can't launch the DLC?

There's currently a bug with one of dialogues that may lead to a halted progress, it will be removed in a hotfix within nearest few days.

13 Mar


Originally posted by ElevatedPhase

Any update on a timeline for a Series X hot fix for the dlc? It appears neither the wolf spirit, or other forest spirit interactions are functioning. Basically a hard stop on any character progression.

Should be there before the end of the week. Maybe even tomorrow if all goes well.


Originally posted by suitable_character

Oooh that's a bummer. I didn't know that. Then it's complete nonsense that the game is listed on sale. I can see that Deep Silver sells it now. I think it's pretty unethical to sell a broken product, without any intention of fixing it, and without any indication about its state.

That is correct, the rights for Kingmaker were lost back in 2019, even before its console release. After a few months outlined in a contract, we've stopped receiving any funds from it whatsoever. Despite that, for about a year we were updating the game from our own funds, but eventually we were forced to stop any development.

Unfortunately there's nothing we can do with the state of the game now. It doesn't belong to us and the current owner isn't interested in reviewing the status despite all our efforts.

12 Mar


Originally posted by Link21002

Series X issue.

Dialogue with a certain spirit in the forest temple cuts off when asking about the demonic locust and halts progression of the DLC :(

Hello! A known issue already hotfixed on PC, console fixes coming soon too.


Originally posted by DreadedChalupacabra

Was watching Lorespire stream this last night and he got a level right before the Minahgo fight. The game was pausing when he tried to level and would not let him level his dragonblooded shifter main character. Every npc could level, his character couldn't. Here's a youtube of it. Timed at 3:36:21.

This doesn't look good for sure. Will investigate.

Update: workaround seems to be to level up in human form.


Originally posted by Hereforeons

Hello Owlcatstarrok,

a very simple question: Will we be getting any more patches for WotR in the near future (and I don't mean several months later)? What's your plan? Or is Owlcat more concerned with the Dlc's and Warhammer?

I would be very grateful if you could give me the feeling and the hope that you continue to work on WotR in the next time. 🙏🏻🙏🏻

Thank you.

Big patches come out every month or two on average. There's no plan to cease doing that for now, there's still a lot of work to do.


Originally posted by ChemicalBaseRBlong

u/owlcatstarrok I just wanted to reach out and say after a few days of playing on the new patch (PS5) I do notice a much smoother experience in the early game. I play entirely turn based and the battles no longer stutter while stopping or starting. Thank you to the team for continuing to improve the game. I would still really appreciate some better visuals but really if the game looked as it does now with no bugs eventually it would go down as one of the best modern RPGs to me.