Original Post — Direct link

After Talking with Ivaldi, a cut scene starts, after the Cutscene iam unable to control Eivor anymore , all i can do is End the Game and Return to desktop / Return to title Screen. Tried it several times , no chance to get through it.

Regards

22 days ago - Ubi-WheelyDuck - Direct link

Hey @shalea174,

Sorry to hear that you have trouble where you are unable to progress in this quest.

As a first troubleshooting step I would advise to complete our PC troubleshooting steps in full. These steps help by configuring your device for the game and ensure no missing files could be causing this issue.

If after following those steps you find the issue persists, it would be great if you could share a video with us using a link from a third party video sharing website.

Many thanks.

19 days ago - Ubi-LadyBlue - Direct link

Thanks for getting us the video clip @shalea174.

Are you able to reload a previous save and see if you're unable to control Eivor after that cutscene?

19 days ago - UbiSushiVamp - Direct link

@shalea174 Thanks for that information! When you reloaded the save and were able to continue past the cut scene when did Eivor get stuck again?

12 days ago - Ubi-LadyBlue - Direct link

I'm glad changing the graphics quality worked for you @shalea174! 😊

Let me know if there's anything else I can help with!